Skip to main content
OCLC Support

Mass delete stockitems

Learn how to mass delete stockitems in Amlib.

Stockitem Mass Change is useful for maintenance of Stockitem Records. The procedure is to firstly create a Saved file within Stockitem Module then we mass delete the items within the file.

NOTE:

MassItemDeletion will only become available after displaying a Saved File as the File references are used to determine which Stockitems on the Database will be deleted.

Creating the saved file with Stockitems for deletion

There are three different ways to conduct the query within Amlib to collate the stockitems necessary to save to the Stockitem File. Simply choose from either of the following three suggested methods depending on your needs.

To create a File in Stockitem, either:

  • Wand into File
  • Conduct a Query in Stockitem
  • Perform a Where Search or

Option 1 - Wand into file

  1. In Amlib navigate to Main > Stockitem > Stockitem
  2. Then select File > WandIntoFile
  3. F4 Select to choose a File. If a suitable File does not exist, F1 New, type a description eg. Mass Deletions and select F3 Save

     Note: If a suitable File does exist, but items are already in the File which need to be excluded, highlight the File and select F2 Empty

  4. Select the File by highlighting the File and pressing F9 Select
  5. Wand the barcodes of the items to be included in the File. As you wand the items you will notice the number of items increase for the File on the taskbar of the Stockitem screen
  6. Once you have wanded all the items, select File. You will see a tick next to the WandIntoFile

Option 2 - Conduct a query in Stockitem

  1. Perform a query to select the Stockitems to change, save the results into a File by selecting File > Save All or Save Marked or SaveNotMarked (as appropriate).
  2. If a suitable File does not exist, select F1 New type a description and select F3 Save

     Note: If a suitable File does exist, but items are already in the File, which need to be excluded, highlight the File and select F2 Empty

  3. Once the File has been created or emptied, select the File by highlighting the File and pressing F9 Select
  4. The items can then be mass changed as shown under the heading below “Deleting the Items”

Option 3 - Where search

  1. Where Searches can be used for creating Files in Stockitem. Set the parameters as required. For example, those items not counted in a Stocktake that are DVDs.
  2. Choose F7 QtoFile
    • If a suitable File does not exist, select F1 New, type a description and select F3 Save
    • If a suitable File does exist, but items are already in the File, which need to be excluded, highlight the File and select F2 Empty.
  3. Select the File by highlighting the File and pressing F9 Select

Deleting the items

Items that are On Loan, Reserved, have Memos or are Subsidiary or Master items will NOT be deleted

  1. After saving the File, close the Table and go back to the Stockitem Details screen
  2. Select File > DisplayFile. Highlight the appropriate File and select F9 Select
  3. When the items display, highlight all the items in the table and choose MassItemDeletion from the Table menu
  4. Select the appropriate option for the Mass deletion. The Mass Delete Items Dialogue box will display, with options for the Items:
    • Confirm Delete Item Message Required? : Only select if a confirmation message is required for every item
    • Last Item Message for Cat Required? : Only select if a confirmation message is required for every item

    It also has options for the Catalogue
    • Delete Catalogue if Last? Select this when you wish to delete the Catalogue if after deleting the highlighted item, it will no longer have any Stockitems attached
    • Confirm Delete Cat. Message Required? Only select if you wish to check every Catalogue before deletion



    Catalogue File

    If a Catalogue record has no more items after an item is deleted then instead of ticking Delete Catalogue if last option, it is possible to save the records into a File to check later. If this option is chosen click GetFile.
    1. The Catalogue Saved Files window will display
    2. Select a File or select F1 New and create a new File
    3. Enter a description
    4. Press F3 Save
    5. Press F9 Select
  5. Click OK
  6. The items will start deleting

 Note: Most sites select only Delete Catalogue if last and none of the other options as you have already confirmed by highlighting the items!

 

  • Was this article helpful?