Skip to main content
OCLC Support

If we have ILLiad Authentication going into 9.0 what should we be prepared to happen with the passwords

Symptom
  • To upgrade to 9.0 and using ILLiad Authentication, there are new password requirements that require users to change passwords the first time patrons and librarians sign in.  Here is what to expect:
Applies to
  • ILLiad
Resolution

All patrons and staff will need to change their Passwords. 

1.  Information on how complex you want to make the passwords is found here for Staff Password Complexity in the ILLiad 9.0 FAQ page.

2.  If the Passwords have been set  to be required to update, they can be set up to Expire. Information is found in the User Password Expiration documentation.

3.  And for ILLiad Basic Authentication Requirements for your patrons.

For self-hosted sites using RemoteAuth Authentication with no patrons using ILLiad authentication, update the Patron records so that they do not have an AuthType of ILLiad. That means the ILLiad Authentication box will not be checked for the patron records.  To do this, run this SQL Query if you are a single site:

Update Users

Set Authtype='Default'

go

 

For shared sites not using ILLiad Authentication:

Update UsersALL

Set Authtype='Default'

go

 

For example: ABC, CBS, and NBC and only ABC will be only using RemoteAuth for all their patrons, the query is:

Update UsersALL

Set Authtype='Default'

Where NVTGC='ABC'

go

 

Hosted site should let OCLC support know before you upgrade if some of the patrons will be using ILLiad Authentication, or if all of the Patrons will be using RemoteAuth Authentication.  Support will make the adjustment during the Upgrade process. 

In addition to patrons having to possibly change their passwords, the Librarians will have to change their password when upgrading to 9.0. Once a password is updated, it cannot be used again.  So upon updating from 8.7 to 9.0, and with username "Shazam," then users could not go to another computer in 8.7 and use the username "Shazam" again to upgrade the next computer to 9.0.  If that is the only username the user has, then they would need to download 9.0.1.0 and install it.  After the install, open up the ILLiad Client using "Shazam" and the new password that was created.

An example of what the password change page looks like is attached .

If you have questions, contact OCLC Support.

Page ID
15697