Skip to main content
OCLC Support

Does ILLiad require Adobe Acrobat to open PDF files?

Applies to
  • ILLiad
Answer

Yes, for Electronic Delivery, Adobe acrobat is needed.

Additional information

Delivering Articles Electronically

Page ID
32363

 

  • Was this article helpful?