Skip to main content
OCLC Support

Saved searches

Discover saved searches in Folio and how to configure them in OLIB Web.

Saved Searches in Folio enable the end user to save specific search criteria so that the search can be re-run at any time. The end user has to be logged in to use this facility.

Whenever the user re-runs the search, the results are potentially updated, depending on what has changed in the catalogue.

 Note: any saved searches that the end user created originally through WebView, will automatically become available in Folio depending on the configuration below.

Save search in Folio

  1. The user carries out a search using any terms, filters and sorting as required.
  2. They click the Actions on selected items drop down and select Save search:

Actions on selected items drop down, showing Saved Search.

  1. Folio displays a pop up window to give the search a name:

Saved search pop up window to name the search.

  1. The search becomes available for subsequent re-use in the Search Options menu:

Search Options drop down showing Saved Searches.

  1. When the user selects the search, Folio displays the results in a standard hitlist with Search results for ‘[search term]' displayed in the centre of the hitlist header bar.

Enable the saved search function

  1. Go to User Management Reference Data> User Categories and set Can Save Searches to Yes for those categories of user who should have the saved search function enabled.
  2. Go to OPAC> Configuration Settings and search for action_array. Make sure that the entry for Save Search has Include? = Yes and Value 2 set to 9
Config Block g_title_hitlist
Setting action_array 
Value "Save search"
Value 2 9
Sequence 1 10
Sequence 2 7
Include? Y
  1. Go to OPAC> Configuration Settings and search for g_statistics. Make sure that Include? = Yes. (This makes the search strings available for retrieval from the database as and when the users require):
Config Setting ID Interface Config Block Setting Value Sequence 1 Sequence 2 Include?
604679 1 gno_startup g_statistics "Y" 29 0 Y

Enable the saved search option in the menu

The Saved Search option is visible in Folio in the Search Options menu if the user is logged in and has previously saved at least one search.

  1. Go to OPAC> Configuration Settings and search for smenu_options:
Config Setting ID Interface Config Block Setting Value Sequence 1 Sequence 2 Include?
604858 1 g_searchmenu smenu_options "mss_array" 1 9 Y
604857 1 g_searchmenu smenu_options "mss_spacer" 1 8 Y
  1. Ensure the entry for "mss_array" has Include?=Yes. Value 2 is the text for the "My Saved Searches" option if you want to edit it.
  2. Still in the smenu_options array, open the "mss_spacer" entry. In Value 2 enter e.g."-----------" to act as a delimiter between normal public search options and the user Saved Searches, e.g:

Keyword
Title/Author
Advanced
Subject
-----------
My Saved Searches

Refresh your Folio to apply the configuration changes.

 

  • Was this article helpful?