Skip to main content
OCLC Support

License Key Expired too far in the future

Symptom
  • After Upgrading to version 6.6.2 you get the following error message: Current license key expired on 2019-12-31 09:00:00 (too far in future; clock issue).
Applies to
  • EZproxy version 6.6.2
Resolution

To resolve this you will need to reapply your EZproxy WSkey using the steps below:

  1. Log onto your EZproxy Server.
  2. Stop EZproxy from running as a service.
  3. Remove EZproxy as a service
  4. Install your EZproxy WSkey:
  • Windows Command:
ezproxy -k 123456789101112
  • Linux Command (Must be run as root):
./ezproxy -k 123456789101112
  1. Add EZproxy back as a service.

After this has been completed the message should go away.

Page ID
24760