Skip to main content
OCLC Support

EZproxy 7.1 and the RunAs directive

Applies to
  • EZproxy 7.1
  • Utilizing RunAs directive


Answer

EZproxy creates a /security directory upon upgrade to version 7.1.  The RunAs user needs to have permissions to this directory.  If it doesn't, EZproxy will not run and you may find a combination of these error in the messages.txt file:

  • SQL errors
  • Guardian failures
  • Authentication validation errors
  • Failed to start

 

  • Additional information

More info on RunAs can be found here.

Page ID
36542

 

  • Was this article helpful?