Skip to main content
OCLC Support

EZproxy v6.4.4 release notes

Release Date: May 2018

Operating system requirements

EZproxy v6.4.4 is supported under two different operating systems:

The supported versions of these operating systems along with their minimum hardware requirements can be found at Requirements.

Recommended actions

For this release, we recommend that you review the following checklists and complete the relevant tasks. These checklists identify updates that we have determined as significant for most institutions. We encourage you to review all of the items in the release notes to determine whether there are other items that might require additional action or follow up by your institution.

Administrative actions

These items require immediate action or decisions.

Action

If you are upgrading from an EZproxy version earlier than v6.0, you will need an EZproxy Web Services Key (WSKey). To obtain a WSKey, you will need to have a current, annual subscription. EZproxy moved to the annual subscription model in July 2013, so if you purchased your EZproxy subscription prior to that time, you will need to update.

To purchase an annual subscription, you can request a quote, and you will be provided with a quote and information about how too subscribe. If you are uncertain if your subscription is current, please email orders@oclc.org.

If you have already upgraded to V6.x, your existing WSKey will work with this upgrade.

Review EZproxy and OpenSSL, especially if you are upgrading from a version older than V5.7.44. EZproxy V6.4.4 has many security updates that may make previous configurations in your config.txt file unnecessarily, and you can remove certain directives after installing V6.4.4.

 

New features and enhancements

MaxMind GeoIP Library updated to version 2

MaxMind makes the IP geolocation library used by EZproxy. In April 2018, they discontinued support for their version 1 library and database form
at often referred to as GeoIP. EZproxy has been updated to support version 2 which is often referred to as GeoIP2.

As of EZproxy 6.4.4, EZproxy dropped support for original GeoIP files and added support for GeoIP2. The Location directive is still used to activate geolocation support. Typical usage now is:

Location -file=GeoLite2-City.mmdb

If an existing site updates from an earlier version that points to a version 1 file, EZproxy will report:

Location file is not a GeoIP2 mmdb file

to messages.txt, but will still startup. EZproxy does not store location information, but rather looks it up as needed, so no data will be lost in this instance.
Once config.txt has been updated to point to a GeoIP2 file and restarted, everything will return to normal.

MaxMind provides access to the free version of their database file at https://dev.maxmind.com/geoip/geoip2/geolite2/. The correct file to download is the “MaxMind DB binary, gzipped” version.

This file must be downloaded to the directory where EZproxy is installed. The file is distributed as a tar.gz file which must be expanded to access the mmdb file that EZproxy requires. For Linux, the tar command can be used to expand the file. For Windows, a utility such as 7z will be required.

EZproxy now uses OpenSSL 1.0.2o

EZproxy 6.4.4 was built with the most current Long Term Support release of OpenSSL (1.0.2o), which was released on March 27, 2018.

For more information, see EZproxy & OpenSSL.

Important links

Product website

More product information can be found at: http://www.oclc.org/ezproxy.en.html

Support websites

Support information for this product and related products can be found at:

 

 

 

  • Was this article helpful?