# Tasks for start or end of year

Last updated: Wed, 04 Nov 2020 14:26:32 GMT

Find a checklist of tasks for the start or end of the year in Amlib with accompanying instructions.

## Checklist of tasks for start or end of year

<table>
<thead>
<tr>
<th>TASK</th>
<th>SCREEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deletion of students who have left – for example: Year 7s, Year 12s, Staff</td>
<td>Main &gt; Borrowers &gt; Borrower</td>
</tr>
<tr>
<td>Changes of Borrower Class Name/Descriptions (if applicable)</td>
<td>Main &gt; Borrowers &gt; BorrowerClasses</td>
</tr>
<tr>
<td>Class names/descriptions may need to be altered to reflect new teachers' names, etc.</td>
<td></td>
</tr>
<tr>
<td>Import of new students using data from School Administration system (or manually change students through global changes) Separate notes are available if necessary</td>
<td>Main &gt; Borrowers &gt; BorrowerImport</td>
</tr>
<tr>
<td>Add new staff (manually or through School Administration system)</td>
<td>(Import) Main &gt; Borrowers &gt; BorrowerImport</td>
</tr>
<tr>
<td>(Manual) Main &gt; Borrowers &gt; Borrower</td>
<td></td>
</tr>
<tr>
<td>Date Changes for DEFAULT (global) all items must be returned by, end of term, end of semester, end of year, etc.</td>
<td>Main &gt; Supervisor &gt; Installation</td>
</tr>
<tr>
<td>Add final Return By Dates to Borrower Types (as applicable) – for example: Term Loans or Year Groups who leave earlier – i.e. Year 11 and/or 12</td>
<td>Main &gt; Borrowers &gt; BorrowerTypes</td>
</tr>
<tr>
<td>Add closed dates to calendar (Including holidays)</td>
<td>Main &gt; Supervisor &gt; Installation</td>
</tr>
<tr>
<td>Ensure that Backup procedures are in place and that logs of Backups are regularly checked</td>
<td>This is very important – contact our office if you are in doubt…</td>
</tr>
<tr>
<td>Check <em>Amlib</em> version: has it been updated in the last year?</td>
<td>Main &gt; Base &gt; AboutRelease for your release dates. Amlib Version 6.0 was</td>
</tr>
<tr>
<td>TASK</td>
<td>SCREEN</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>--------</td>
</tr>
<tr>
<td>Are you updating your server or installing new PCs</td>
<td>Please consult Amlib Support for more information prior to beginning</td>
</tr>
<tr>
<td>How to obtain Online Help</td>
<td>Press Ctrl + H</td>
</tr>
</tbody>
</table>

**Borrower records**

A new calendar year for schools means new term times, new students, students who need deleting - some which probably still have loans or memos!

- **Deletions**: Non returning Students
- **Additions**: New students either manually or through a download from the School Administration system (for example: SIS, Maze, Synergy etc.)
- **Changes /Updating**: Dates, Class descriptions

**Deletions**

It is best to delete students who have left **BEFORE** adding new students – for example: in a Primary School this will be the Year 7 students; in a Secondary School the Year 12 students can be found and deleted.

The following instructions are for a Primary School:

1. Launch the **Amlib** client
2. Go to **Main > Borrowers > Borrower** – the Borrower Details screen will display:
3. Search for the Year 12 students: in the Type field, type the code – for example: **Y12** and click the **F5 Query** button.

4. The results will display in a Borrower List:
5. Select the Borrowers to be deleted by highlighting the rows – to select and highlight all the Borrowers:
   
a. Press the `Ctrl` key and click with the left mouse button first borrower in range and then run the mouse down the left column, or
   
b. Select first name in list and then Press `shift` and select the last Borrower in the range (useful for highlighting all of a big list!)

6. From the menu, select **Table > MassBorrowerDelete** – a prompt with the following message will display: **You are about to delete the selected Borrowers. Do you want confirmation of delete message?**

![Borrower Details - Mass Borrower: Delete](image)

**Hint:** You have already highlighted the borrowers for deletion. Confirming each and every borrower to be deleted will slow down the process.
**No:** All borrowers highlighted in the table will be deleted unless the borrower has loans, reservations or memos. No messages display.

**Yes:** Each borrower’s ID will display. Messages will also display if the borrower cannot be deleted (for example: the borrower has loans, reservations or memos, etc).

---

**Delete single patron records**

1. Search by Surname in the Borrower Details screen
2. Delete by clicking the **F4 Delete** button – a prompt with the following message will display: **Borrower XXXXX Are you sure you wish to delete this Borrower?**

   ![Borrower Details - Delete](image)

   **Borrower B402 Are you sure you wish to delete this Borrower?**

3. Click the **Yes** button to delete the borrower record – a prompt with the following message will display: **The Borrower has been Deleted**

   ![Borrower Details](image)

   **The Borrower has been Deleted.**

4. Click the **OK** button

---

**Note:** Students with Loans, Reservations or Memos will not be deleted. If a student has left with items showing on loan, if the books are unlikely to be returned, it is suggested that these items be returned from the patron and either made lost or deleted so that the student (or teacher!) can be deleted from your database

---

**Additions**

New students need to be added. This can be done manually or automatically from your School Administration system. See *Appendix A: Borrower Import* for more detail or email Support for separate notes.

Barcodes will need to be added to the records. This can be done by selecting the New File created in the Import of patrons, click **F9 Select** to choose the file.
1. Double-click the first borrower on the list and wand the new barcode
2. Click the F3 Update button to save changes
3. Click the F9 > button to go to the next patron on your list, etc.
Start of year dates

There are two sets of dates that require adjusting at the start of the year: the Supervisor Installation settings and the Borrower Type settings.

Supervisor settings

Default

1. Launch the Amlib client
2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display
3. Select the Circulation tab

![Supervisor Settings](image)

4. Adjust the following settings:
   a. All items must be returned by the following date:
   b. All Semester loans are due back on the following date:
   c. All Term loans are due back on the following date:
   d. All Year loans are due back on the following date:

https://help.oclc.org/Library_Management/Amlib/Supervisor/Tasks_for_start_or_end_of_year

Printed: Sun, 21 Aug 2022 02:27:30 GMT
5. Dates must be entered in DD/MM/YYYY format – for example: 15/12/2012
6. Click the F3 Save button
7. For these settings to take effect you must exit and restart the Amlib client

**Location**

It is also possible to adjust these settings by individual Location, allowing for a different set of dates to be entered. It is very important to check your other locations to make sure that old dates are not saved in there.

1. Launch the Amlib client
2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display
3. From the menu, select Installation > Choose Location – the Installation location prompt will display
4. Select a location (for example: Chelsea Library) and click the OK button – the Installation screen for that location will then display
5. Select the Circulation tab

![Image of Amlib installation screen]

6. If you would like to use the DEFAULT page settings, then you can leave the date settings in this location table blank, otherwise adjust the following settings (these settings will apply only to that location):
   a. All items must be returned by the following date:
   b. All Semester loans are due back on the following date:
c. All Term loans are due back on the following date:
d. All Year loans are due back on the following date:

7. Dates must be entered in **DD/MM/YYYY** format – for example: **15/12/2012**
8. Click the **F3 Save** button
9. Repeat for all other circulating locations (including WEB – the location used by the NetOpacs)
10. For these settings to take effect you must **exit** and **restart** the Amlib client

## Borrower settings

### Borrower types

1. Launch the Amlib client
2. Go to **Main > Borrowers > BorrowerTypes** – the Borrower Types screen will display:

   ![Borrower Types Screen](image)

   For each borrower type it is possible to enter a Return By Date that overrides the Supervisor Date settings and allows for return dates to be set earlier (if the Return By Date is set after the Supervisor Date settings, then these Supervisor Dates will be the cut off point for returns)

3. Enter a date in **DD/MM/YYYY** format in the Return By Date field of a selected borrower Type – for example: **15/11/2013**
4. Repeat for any borrower Type where the Return By Date is required to be different
5. Click the **F3 Save** button when complete
6. Exit the Borrower module (**Ctrl-L**) for these settings to take effect

## Classes / Groups

Some of the Class Name / description may need to be change because of staff, room changes, etc.
1. Launch the Amlib Client

2. Select **Main > Borrower > Borrowers > BorrowerClasses** – the Borrower Classes screen will display:

![Borrower Classes Screen](image.png)

3. Make the change/s

4. Click the **F3 Save** button when complete

5. Select **Main > Borrower > Borrowers > BorrowerGroups** – the Borrower Groups screen will display

6. Make the change/s

7. Click the **F3 Save** button when complete

### Mass borrower change

This process can be used to change Borrower Group, Type, Class, etc. The example used here is Borrower Group.

1. Launch the Amlib client

2. Go to **Main > Borrowers > BorrowerWhere** – the Borrower Where screen will display

3. Create a Where clause – for example: Group = **CHI** (this will search for all Borrowers who are in that particular group)
a. Highlight the field to search on: **Group**

b. Choose Operator: **=**

c. Enter the Where condition, or the exact data you want to find – for example: **CHI**

d. Click the Paste button to insert the clause into the table

4. Click on the **F7 QtoFile** button – the Borrower Saved Query Results screen will now display:

5. Click on the **F1 New** button to create a new Saved File

6. Type in a name for the file in the Details column – for example: **Groups to Change**

7. Click on **F3 Save** button

8. Highlight the new Saved File and click on the **F9 Select** button to save results to this file
9. A prompt with the following message will display: **The 'XXXX' file contains XX borrowers.**

10. Click the **OK** button

11. Go to **Main > Borrowers > Borrower** – the Borrower screen will display

12. Select **File > DisplayFile** – the Borrower Saved Query Results file screen will display:

<table>
<thead>
<tr>
<th>Details</th>
<th>Allow other operators to access this file (Y/N)</th>
<th>Qty</th>
<th>Last Updated</th>
<th>File No</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dup Aug 2011</td>
<td>Y</td>
<td>1</td>
<td>09/08/2011 8:56:50 PM</td>
<td>3187</td>
</tr>
<tr>
<td>New Aug 2011</td>
<td>Y</td>
<td>1</td>
<td>09/08/2011 8:56:50 PM</td>
<td>3185</td>
</tr>
<tr>
<td>Upd Aug 2011</td>
<td>Y</td>
<td>4</td>
<td>09/08/2011 8:56:50 PM</td>
<td>3186</td>
</tr>
<tr>
<td>Matched Pictures 2011</td>
<td>Y</td>
<td>2</td>
<td>08/08/2011 9:38:46 PM</td>
<td>3155</td>
</tr>
<tr>
<td>List</td>
<td>Y</td>
<td>4</td>
<td>27/07/2011 12:16:29 PM</td>
<td>3128</td>
</tr>
<tr>
<td>Mass Update</td>
<td>Y</td>
<td>34</td>
<td>19/07/2011 10:43:53 AM</td>
<td>2972</td>
</tr>
<tr>
<td>Groups to Change</td>
<td>Y</td>
<td>0</td>
<td>09/08/2011 11:08:35 PM</td>
<td></td>
</tr>
</tbody>
</table>
13. Highlight the required Saved File and click on the **F9 Select** button to display the file

14. From the Borrowers List screen, select **Table > Mass Borrower Change**

15. The Mass Change of Borrowers within a File screen will display:

16. Enter the following settings:
a. Select the field you wish to change for all stockitems in the file – for example: **Group**
b. Type in the new value example, which is what you are changing all stockitems to be – for example: **DUT**
c. Click on the **Paste** button to insert the new criteria into the bottom table
d. Click on the **F3 Update** button to start the mass change

17. This will change all the Borrower Groups in this file so that they are now Dutch – the Borrower List screen will display

![Borrower List - 8 rows](image)

**Calendar**

**Days closed**

If the Libraries at all campuses are closed on common days (for example: weekends) it is possible to set these days closed in the **Supervisor** module:

1. Launch the **Amlib** client
2. Go to **Main > Supervisor > Installation** – the Installation (**DEFAULT**) screen will display
3. Select the **Circulation** tab
4. Adjust the following settings:
   - Days of the week when ALL Locations are closed (Sun=0, Sat=6) – type in 06 if closed Saturday and Sunday
5. Click the **F3 Save** button when complete
6. Exit and restart the *Amlib* client for the new settings to take effect

**Holidays**

It is possible to mark days (holidays) to be 'closed' in the calendar (for example: Easter).

When an item is issued, the program will ensure that it the item is not due for return on closed dates. Reservations will not be due for collection on closed dates. Dates may be entered as far in advance as desired.

To mark a date as a closed:

1. Launch the *Amlib* client
2. Go to **Main > Supervisor > Calendar** – the Calendar screen will display
3. Use the **F7, F8, F9** and **F10** buttons to navigate to a month where you want to set a closed date:
4. Select a date with your mouse – for example: 25 December 2012

5. Click the **F2 Set** button – the Holiday prompt will display:

   - Type in a suitable description in the dialogue box – for example **Melbourne Cup** or **Term Break**
   - Click the **OK** button

6. The date will be marked in **red** (indicating it is closed) – the Date and Description will appear in the table to the right of the calendar:
7. Once the dates have been set, click the **F3 Update** button.

8. Exit and restart the *Amlib* client for the new settings to take effect.

Note: Where a Return By date falls on a closed date, the system allocates the next non-closed date past that date.

- Arrow Keys [F7], [F8], [F9], [F10]

To scroll through the calendar you may use the **F7** through **F10** keys:

<table>
<thead>
<tr>
<th><strong>KEY</strong></th>
<th><strong>DESCRIPTION</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>F7</strong></td>
<td><strong>&lt;&lt;</strong></td>
</tr>
<tr>
<td><strong>F8</strong></td>
<td><strong>&lt;</strong></td>
</tr>
<tr>
<td><strong>F9</strong></td>
<td><strong>&gt;</strong></td>
</tr>
<tr>
<td><strong>F10</strong></td>
<td><strong>&gt;&gt;</strong></td>
</tr>
</tbody>
</table>
Remove a closed date

1. To remove a closed date, highlight the date
2. Click the F4 Delete button – this will mark [x] the Closed date for deletion
3. Click the F3 Update button when complete
4. Exit and restart the Amlib client for the new settings to take effect

Copy a closed date to other locations

Closed dates in Calendar can be copied to other Locations.

1. From the menu, select Calendar > Copy To All – a prompt will display asking: This will make every location have exactly the same holiday settings as ‘XXX’. Continue?
2. Click the Yes button – this will copy the closed settings to ALL locations
3. Once complete, a prompt will display with the following message: Calendar successfully reproduced.
4. Click the OK button
5. Exit and restart the Amlib client for the new settings to take effect
Different closed dates for each location

If different closed dates are required for different Locations.

1. From the menu, select Calendar > Choose Location – a Location prompt will display
2. Select the Location and click the OK button
3. The set the closed dates for this Location
4. Click the F3 Update button when complete
5. Exit and restart the Amlib client for the new settings to take effect

Frequently asked questions

Please visit the OCLC website at https://www.oclc.org/support/services/amlib/faq.en.html to find small video clips and answers to some frequently asked questions such as:

1. How to I change my term loan, semester loan and year loan dates?
2. How do I add a new location?
3. I’ve never done a Stocktake before. What does it involve? What should I consider when planning for a Stocktake?
4. How do I start a Stocktake?
5. I’ve started the Stocktake – now how do I Stocktake my collection/items?
6. I’m using a laptop to scan my items. How can I capture the barcodes to load into the Stocktake screen?
7. How do we use the offline module for Stocktake?
8. How do I find missing items?
9. How can I print a list of missing items?
10. I just want to Stocktake one part of the library, not the whole database, how can I do that?
11. How do I close the Stocktake? What happens to the missing items?
12. There are also some answers to common questions as part of the Stocktake overview. For the following Q&As and more:
   1. Can I have more than one Stocktake screen open?
   2. Can I return and issue items during the Stocktake?
   3. How long will it take to do the Stocktake?

Logging help calls

Contact OCLC Support for help with Amlib.

Appendix A
Borrower import

The Borrower Import function enables sites to import borrower data from an Administration system (for example: Cases, EDSAS, Maze, Synergetic, etc) into the Amlib system.

This allows for:

1. New borrowers, including address information, to be included in Amlib without having to manually enter them
2. Updates of existing borrower records with new Type, Class codes, addresses etc.

This function is predominantly used by school libraries at the start of each year/semester to update their student records (or add new ones).

The program allows for the restoration of the old data if necessary.

It has a facility to "map" administrative codes to those used on your Amlib database. They do not have to be the same codes, but need to be matched to the corresponding codes so they will import correctly for each borrower record.

The data file to be imported can be copied from the administrative database onto a USB drive, CD or to a file accessible on the network. You will need to know the exact path so that you can access it during the Borrower download process (from your administrative database). Once the data file has been downloaded from the administrative database, it can be uploaded into Amlib.

The file sent to you should be in one of the following file formats:

- CSV (comma delimited)
- TAB delimited
- Pipe separated (|)

You can have empty fields in your import, but they must be left empty and not have the data moved across. For example: if you didn’t have a Second Name or Preferred Name, you would leave two blank fields where they should be in your file:

Example format (CSV):

- ANDERL,ANDERTON,LAURENCE,WILLIAM,LAURIE,1,RED,B1SJ,1/01/83,M,BB,MR & MRS W B ANDERSON, 5/165 KING EDWARD STREET, BAYSWATER, WA, 6053, 9462 1111

If the above example left out the RED Group code, the data would be:

- ANDERL,ANDERTON,LAURENCE,WILLIAM,LAURIE,1, ,B1SJ,1/01/83,M,BB,MR & MRS W B ANDERSON, 5/165 KING EDWARD STREET, BAYSWATER, WA, 6053, 9462 1111

Pipe (|) separated:

- ANDERL|ANDERTON|LAURENCE|WILLIAM|LAURIE|1| |B1SJ |1/01/83|M|BB|MR & MRS W B ANDERSON|5/
Dates must be formatted in one of the following three ways:

- 11/12/09
- 11/12/2009
- 11 Dec 09

If there are trailing spaces in the data, the program strips these out and causes no problems with the download.

**Format 1: MAZE, Synergetic, CASES, COSYCORNER**

This format contains only 17-18 fields, which should be downloaded into a data file from the administrative software (for example: MAZE, Synergetic, CASES, COSYCORNER, etc.) in the sequence as shown below.

**Mandatory Fields:** The data must include **Borrower Shortname** (Unique ID/BarCode), **Surname** and **Type**. These cannot be left as null fields. Any unused fields should be left blank but included as null fields.

<table>
<thead>
<tr>
<th>FIELD</th>
<th>CSV COLUMN</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. (Unique ID/BarCode)</td>
<td>A</td>
<td>ANDERL</td>
</tr>
<tr>
<td>Borrower Short Name/MAZE Key</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2. Surname</td>
<td>B</td>
<td>ANDERSON</td>
</tr>
<tr>
<td>3. Given</td>
<td>C</td>
<td>LAURENCE</td>
</tr>
<tr>
<td>4. Second Name (only imports initial)</td>
<td>D</td>
<td>WILLIAM</td>
</tr>
<tr>
<td>5. Preferred (overrides Borrower Given)</td>
<td>E</td>
<td>LAURIE</td>
</tr>
<tr>
<td>6. Type</td>
<td>F</td>
<td>1</td>
</tr>
<tr>
<td>7. Group</td>
<td>G</td>
<td>RED</td>
</tr>
<tr>
<td>8. Class</td>
<td>H</td>
<td>B1SJ</td>
</tr>
<tr>
<td>FIELD</td>
<td>CSV COLUMN</td>
<td>EXAMPLE</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------------</td>
<td>---------------------------------</td>
</tr>
<tr>
<td>9. Date of Birth (or date of entry depending on what is used by the admin. database)</td>
<td>I</td>
<td>1/01/83</td>
</tr>
<tr>
<td>10. Sex</td>
<td>J</td>
<td>M</td>
</tr>
<tr>
<td>11. Location</td>
<td>K</td>
<td>BB</td>
</tr>
<tr>
<td>12. Contact name</td>
<td>L</td>
<td>MR &amp; MRS W.B. ANDERSON</td>
</tr>
<tr>
<td>13. Contact Address Line 1</td>
<td>M</td>
<td>5/165 King Edward St</td>
</tr>
<tr>
<td>14. Contact Address Line 2</td>
<td>N</td>
<td>Bayswater</td>
</tr>
<tr>
<td>15. Contact Address Line 3</td>
<td>O</td>
<td>WA</td>
</tr>
<tr>
<td>16. Postcode</td>
<td>P</td>
<td>6053</td>
</tr>
<tr>
<td>17. Contact Phone Number</td>
<td>Q</td>
<td>9462 1111</td>
</tr>
<tr>
<td>18. Email (Optional)</td>
<td>R</td>
<td><a href="mailto:john.smith@oclc.org">john.smith@oclc.org</a></td>
</tr>
</tbody>
</table>

**Format 2: SIS (WA Education Dept)**

This format contains only 22 fields, which should be downloaded into a data file from the Administrative software (SIS) in the sequence as shown in below.

Note: All files must be in a standard .CSV format. Any unused fields should be left blank but included as null fields.
<table>
<thead>
<tr>
<th>FIELD #</th>
<th>FIELD NAME</th>
<th>TYPE &amp; SIZE</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>(Unique ID) ID/REF/BarCode</td>
<td>Alpha Numeric 15</td>
<td>1234</td>
</tr>
</tbody>
</table>
| 2       | Type       | Alpha Numeric 1 | 1. student  
2. teaching staff  
3. Non Teacher |
<p>| 3       | Date of Birth | Date       | 12 JAN 1993 |
| 4       | Sex        | Alpha Numeric 1 | M / F   |
| 5       | Surname    | Alpha Numeric 40 | Smith |
| 6       | First name | Alpha Numeric 40 | Jonathon |
| 7       | 2nd name   | Alpha Numeric 20 | Peter  |
| 8       | 3rd name   | Alpha Numeric 40 | Paul   |
| 9       | Preferred name | Alpha Numeric 40 | John  |
| 10      | Addr line 1 | Alpha Numeric 40 | 151 Royal St |
| 11      | Addr line 2 | Alpha Numeric 40 |         |
| 12      | Addr line 3 | Alpha Numeric 40 |         |
| 13      | Suburb     | Alpha Numeric 50 | East Perth |
| 14      | State      | Alpha Numeric 40 | WA      |</p>
<table>
<thead>
<tr>
<th>FIELD #</th>
<th>FIELD NAME</th>
<th>TYPE &amp; SIZE</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>15</td>
<td>Postcode</td>
<td>Alpha Numeric 10</td>
<td>6004</td>
</tr>
<tr>
<td>16</td>
<td>Phone 1</td>
<td>Alpha Numeric 30</td>
<td>9264 1111</td>
</tr>
<tr>
<td>17</td>
<td>Phone 2</td>
<td>Alpha Numeric 30</td>
<td>9264 1113</td>
</tr>
<tr>
<td>18</td>
<td>E-mail</td>
<td>Alpha Numeric 100</td>
<td><a href="mailto:john.smith@oclc.org">john.smith@oclc.org</a></td>
</tr>
<tr>
<td>19</td>
<td>Parent Salute</td>
<td>Alpha Numeric 60</td>
<td>Mr &amp; Mrs Smith</td>
</tr>
<tr>
<td>20</td>
<td>Class</td>
<td>Alpha Numeric 15</td>
<td>Room 5</td>
</tr>
<tr>
<td>21</td>
<td>Group (Type)</td>
<td>Alpha Numeric 2</td>
<td>4 (K, P 12, up etc)</td>
</tr>
<tr>
<td>22</td>
<td>Entry Date</td>
<td>Date</td>
<td>22 SEP 1998</td>
</tr>
</tbody>
</table>

**Format 3: All Fields/EDSAS (SA Education Dept)**

You must have at least 19 columns, up to 25 columns (with the exception of 22 – see Format 2).

**Mandatory Fields:** Borrower Shortname (Unique ID/BarCode) and Borrower Type. Additionally, you need to have data in the Location column even if this does not come from your Admin system. If you do not store patron location against the student in your admin system, you can just put a 1 in every line of the file and match this 1 to your library location later.

Note: If the data file only contains 19 fields the Guardian details are copied from fields 12 – 16. Any unused fields should be left blank but included as null fields.

<table>
<thead>
<tr>
<th>FIELD</th>
<th>CSV COLUMN</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. (Unique ID /BarCode) Borrower Short Name</td>
<td>A</td>
<td>ANDERL or B9988</td>
</tr>
<tr>
<td>FIELD</td>
<td>CSV COLUMN</td>
<td>EXAMPLE</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>2. Surname</td>
<td>B</td>
<td>ANDERSON</td>
</tr>
<tr>
<td>3. Given Name</td>
<td>C</td>
<td>LAURENCE</td>
</tr>
<tr>
<td>4. Middle Name (only imports initial)</td>
<td>D</td>
<td>WILLIAM</td>
</tr>
<tr>
<td>5. Preferred Name (overrides Given)</td>
<td>E</td>
<td>LAURIE</td>
</tr>
<tr>
<td>6. Type</td>
<td>F</td>
<td>1</td>
</tr>
<tr>
<td>7. Group</td>
<td>G</td>
<td>RED</td>
</tr>
<tr>
<td>8. Class</td>
<td>H</td>
<td>10A</td>
</tr>
<tr>
<td>9. BirthDate</td>
<td>I</td>
<td>01/01/91</td>
</tr>
<tr>
<td>10. Sex</td>
<td>J</td>
<td>M</td>
</tr>
<tr>
<td>11. Location</td>
<td>K</td>
<td>BB</td>
</tr>
<tr>
<td>12. Address 3 Line 1 (Guardian Name)</td>
<td>L</td>
<td>MR &amp; MRS ANDERSON</td>
</tr>
<tr>
<td>13. Address 1 Line 1</td>
<td>M</td>
<td>5/165 King Edward St</td>
</tr>
<tr>
<td>14. Address 1 Line 2</td>
<td>N</td>
<td>Bayswater</td>
</tr>
<tr>
<td>15. Address 1 Line 3</td>
<td>O</td>
<td>WA</td>
</tr>
<tr>
<td>16. P/Z Code</td>
<td>P</td>
<td>6053</td>
</tr>
</tbody>
</table>

https://help.oclc.org/Library_Management/Amlib/Supervisor/Tasks_for_start_or_end_of_year
Printed: Sun, 21 Aug 2022 02:27:30 GMT
<table>
<thead>
<tr>
<th>FIELD</th>
<th>CSV COLUMN</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>17. Address 1 Tel.</td>
<td>Q</td>
<td>08 9462 1111</td>
</tr>
<tr>
<td>18. Email</td>
<td>R</td>
<td><a href="mailto:laurie@oclc.org">laurie@oclc.org</a></td>
</tr>
<tr>
<td>19. (Other ID) Ref2</td>
<td>S</td>
<td>18846</td>
</tr>
<tr>
<td>20. Address 3 Line 2</td>
<td>T</td>
<td>8 Osborne Rd.</td>
</tr>
<tr>
<td>21. Address 3 Line 3</td>
<td>U</td>
<td>Innaloo</td>
</tr>
<tr>
<td>22. Address 3 Line 3 (merges with above)</td>
<td>V</td>
<td>WA</td>
</tr>
<tr>
<td>23. Address 3 Postcode/Zip Code</td>
<td>W</td>
<td>6017</td>
</tr>
<tr>
<td>24. Address 3 Tel.</td>
<td>X</td>
<td>08 9754 0000</td>
</tr>
<tr>
<td>25. Mobile/Cell</td>
<td>Y</td>
<td>0425 113 655</td>
</tr>
</tbody>
</table>

**How records are matched**

The records will be matched in the following way:

1. **Unique ID/Other ID** – If the Unique ID/Other ID (BarCode/Ref2) from the file is found in Borrower, then the information for that patron will be overwritten with the data there, regardless of whether or not the name is the same. So if a student changes their surname, the new surname would come across in the import as long as the Borrower ID/Barcode is identical.

2. **Surname/Given Name** – If no matching Borrower ID/BarCode is found, the system will then do a search for any matching surnames and first names. If there is one match found, the system will overwrite that record with the data in your file.

3. **Date of Birth** – If more than one match is found for the surname and first name, the system will then try to locate the correct one using the date-of-birth. If a matching date-of-birth for that surname and first name is found, that record is updated. If the birthdates for these Borrowers are null then the Borrowers are considered duplicates (and the system creates a new record with an auto-generated **AMLIB BarCode**).
In the example below John Goldsmith changed his Surname to Smith. The BarCode in the Amlib borrower record was identical to the Unique Import Key (Unique ID), therefore the details were updated, showing the Borrower details with the new Surname.

<table>
<thead>
<tr>
<th>UPD</th>
<th>Surname</th>
<th>First</th>
<th>Initial</th>
<th>Type</th>
<th>Class</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>UPD</td>
<td>Smith</td>
<td>John</td>
<td>J</td>
<td>Adult</td>
<td></td>
<td>12/06/1968</td>
</tr>
<tr>
<td>NEW</td>
<td>Smith</td>
<td>Sarah</td>
<td>J</td>
<td>Adult</td>
<td>Mrs Harris</td>
<td>16/05/195</td>
</tr>
<tr>
<td>NEW</td>
<td>Peabody</td>
<td>Amy</td>
<td>A</td>
<td>Adult</td>
<td></td>
<td>22/09/199</td>
</tr>
<tr>
<td>NEW</td>
<td>Rumford</td>
<td>Emilia</td>
<td>P</td>
<td>Adult</td>
<td></td>
<td>10/03/197</td>
</tr>
</tbody>
</table>

- The Borrower Import will remove single quotes from any incoming names – for example: O'Brien becomes OBrien.

Suggested ‘Pre-import’ tasks

You may wish to move all year 12 students (or year 6 students – for primary schools) into another class such as Year 13 or Year 7 using Mass Borrower Change. From there you can upgrade all other years and import new students. Any returning year 12 (or 6) students would be updated and moved back to class year 12 (6). All Remainder students can be dealt with as necessary.

Alternatively all students may be mass changed to a generic class via Mass Borrower Change, thus giving all students a single class. When doing then next import, all classes will be changed to the correct class. Any left with the generic class can be dealt with as necessary.

Before starting the import process, check the Type, Group, Class and Location tables in Amlib to ensure all required codes have been created. Check the Location table to ensure that the locations required have a Valid for Borrower setting of Y.

Importing into Amlib

1. Launch the Amlib client
2. Go to Main > Borrowers > BorrowerImport – the Borrower Import screen will display:

3. Click the F1 Open button – the Import File… screen will display:

https://help.oclc.org/Library_Management/Amlib/Supervisor/Tasks_for_start_or_end_of_year
Printed: Sun, 21 Aug 2022 02:27:30 GMT
4. **Browse** to file to be uploaded, select (highlight) it and click on the **Open** button

5. Your data will appear in the Borrower Import screen and a prompt will display with the following message: **All the Type, Group, Class and Location Codes have been loaded from the Import File. Use the ‘Setup’ menu to assign each Imported Code an equivalent Amlib Code before using the ‘Import’ option to update all the Borrowers.**
The data read from the Borrower Import File can be sorted or have the actions calculated prior to importing the data into Amlib.

6. To sort: From the menu, select **Sort By** > and select the sort field – the data can be sorted by **Surname, Given name, Borrower Type, Group or Class**.

7. The calculate action option (**Table** > **Calculate Action**) will read the import data and state whether each student import will be **UPDated, NEW** or a **DUPlicated** student record.

8. If the **F4 Import** button is **greyed** out, it indicates the mapping between the imported codes needs to be setup (or adjusted) to match the codes used within Amlib. If it’s is bolded, the skip ahead to step 13.

9. From the menu, select **Setup** and then select one of the following Borrower fields: **Types, Groups, Classes** or **Locations** – in the example below, we have selected **Types**:

---

https://help.oclc.org/Library_Management/Amlib/Supervisor/Tasks_for_start_or_end_of_year

Printed: Sun, 21 Aug 2022 02:27:30 GMT
Note: If a selection is greyed out, this indicates there are no codes requiring mapping for that field. Once a field has been successfully mapped a **bolded tick** will appear at the front of the selection.

10. A Setup screen will display with two columns: The Imported Type and the Amlib Type. The Imported Type will be the data located in your **Borrower Type** column (Field 6/CSV column F) of your import file. The Amlib Type will be the codes located in the **Main > Borrowers > BorrowerTypes** screen.

![Borrower Type Setup](image)

**Before all the borrowers can be imported, there must be an Amlib Type defined for each Imported Type. Please fill in the table below, then press OK.**

<table>
<thead>
<tr>
<th>Imported Type</th>
<th>Amlib Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adult</td>
<td>A</td>
</tr>
<tr>
<td></td>
<td>B</td>
</tr>
<tr>
<td></td>
<td>H</td>
</tr>
<tr>
<td></td>
<td>I</td>
</tr>
<tr>
<td></td>
<td>J</td>
</tr>
<tr>
<td></td>
<td>M</td>
</tr>
<tr>
<td></td>
<td>S</td>
</tr>
<tr>
<td></td>
<td>S2</td>
</tr>
<tr>
<td></td>
<td>SE</td>
</tr>
<tr>
<td></td>
<td>T</td>
</tr>
</tbody>
</table>

![OK and Cancel buttons](image)

11. For each Imported Type, use the Amlib Type drop-down to select a **Borrower Type** you would like to match (map) it against.

Note: It is possible to map more than one Imported Type to the same Amlib Type.

12. You will need to do this for all the **bolded selections** in the Setup menu – when you have finished all the fields, they will all have a **bolded tick** next to them and the **F4 Import** button will then be active (**bolded**):

![F4 Import button](image)

13. Click the **F4 Import** button – the Borrower Import Files screen will display – this screen allows you to create files to save **New**, **Updated** and **Duplicate** borrowers to. It also allows you to **Overwrite Given name(s) and initial(s)** and to **Use (their) Date of Birth** for unique checking.
14. Type in the filenames, and **tick** the settings you would like to use, then click the **OK** button – a prompt will display asking if you wish to save any changed borrowers to a file for recovery purposes: **It is recommended that all changed Borrowers be written to a text file for recovery purposes. Do you want to save changed Borrowers to a file?**

![Save to File dialog box](https://help.oclc.org/Library_Management/Amlib/Supervisor/Tasks_for_start_or_end_of_year)

**WARNING! This is your insurance for your borrower data and is thoroughly recommended!!**

15. If you click the **Yes** button, a dialog box will display so that you can choose the file name for your original data and where to save it.
Note: In subsequent downloads, the `restore.txt` or `restore.csv` file will already exist and a message will display asking if you wish to overwrite this file. You would normally respond Yes to overwrite the file.

16. Once complete, a prompt will display notifying you that: **The Borrower Import is complete.**

Note: The import process can take several minutes (for example: 1-3 seconds per borrower). The status of the import displays at the bottom of the screen.

17. If borrowers with duplicate Borrower IDs are imported, then you will receive notification of this as part of the completion notice: **The Borrower Import is complete. Some Duplicate Borrower ID’s were detected – these Borrowers have been saved to the ‘Duplicate ID’ saved file.**
File checking

1. An Amlib Unique ID (BarCode) was created for the borrower who had the same ID as someone else (AMLIB0000…)

2. If you go into the main Borrower screen (Main > Borrowers > Borrower) and go to File > DisplayFile you will see your three files for new, updated and duplicate borrowers, and a file for any duplicate IDs if your import had any
Common errors

- The chosen file does not contain Borrower Import records.

  ![Open File](image)

  The chosen file does not contain Borrower Import records.

  This could be caused by either having the information in the correct columns or having headings across the top of your document. Remove any headings and double check your file against the Import formats in this document.

- The chosen file does not contain valid records.
This could be caused by having headings across the top of your import file or it being saved in an incorrect format (for example: .xlsx and not .csv). Please remove any headings, ensuring that it only contains Borrower information and make sure it is in one of the three formats mentioned at the beginning of this document.

Note: It is always a good idea to run a Borrower Import on your test databases first, to ensure no errors happen. If you do not have a test databases, please contact Support via one of the above methods to find out how to set one up.

**Borrower import matching**

The following explains the exact method in which Amlib matches on borrower imported records:

1. Uses the *Unique ID* to *match* on Borrower BarCode
2. If *no matches* then uses the *Unique ID* to *match* on Borrower Ref2
3. If a *Preferred Name* has been Supplied:
   ◦ Matches on *Surname* and *Preferred* EXACTLY
4. If 2, *matches* on *Surname* and *Preferred* EXACTLY
5. If *Date-of-Birth* Supplied:
   ◦ *Searches* on *Surname*, *Preferred* and *Date-of-Birth*
6. If *no matches* and an *Initial* has been supplied:
   ◦ Matches on *Surname*, *Preferred* and *Initial*
7. If *no matches* and an *Initial* has NOT been supplied:
   ◦ Matches on *Surname*, *Preferred* and NULL Initial
8. If *no Date-of-Birth* Supplied:
9. If *no matches* and an *Initial* has been supplied
   ◦ *Matches* on *Surname*, *Preferred* and *Initial*
10. If *no matches* and an *Initial* has NOT been supplied
    ◦ *Matches* on *Surname*, *Preferred* and NULL Initial
11. If *no matches* on *Surname* and *Preferred* EXACTLY
    ◦ *Searches* on *Surname* EXACTLY and LIKE *Preferred* (for example: Preferred%)
12. If *no matches* then *matches* on *Surname* and *Given* EXACTLY
13. If 2, *matches* on *Surname* and *Given* EXACTLY
14. If *Date-of-Birth* Supplied:
- **Searches** on Surname, Given and Date-of-Birth

15. If no matches and an Initial has been supplied:
   - **Matches** on Surname, Given and Initial

16. If no matches and an Initial has NOT been supplied
   - **Matches** on Surname, Given and NULL Initial

17. If no Date-of-Birth Supplied:

18. If no matches and an Initial has been supplied:
   - **Matches** on Surname, Given and Initial

19. If no matches and an Initial has NOT been supplied:
   - **Matches** on Surname, Given and NULL Initial

20. If no matches on Surname and Given EXACTLY
   - **Searches** on Surname EXACTLY and LIKE Given (for example: Given Name)